常见问题解答

如果你在安装 EmEditor 时遇到问题,请先阅读这个

如果你在安装 EmEditor 时遇到问题,请先阅读这个

如果你在安装、卸载或更新 EmEditor 时遇到问题,请参考下面的提示。我们很抱歉给你造成的任何不便。

  1. 如果你用 Trend Micro,Avast,或任何防病毒软件,请暂时禁用该软件并安装 EmEditor。
  2. 关闭所有当前运行的程序包括在任务栏通知区域内的图标。
  3. 通过更新 Windows 和重新启动 Windows,检查 Windows 系统是否是最新的。
  4. 磁盘清理来清理系统文件。要运行磁盘清理,你可以先从任务栏搜索磁盘清理,点击清理系统文件,然后清理所有文件。
  5. 删除在 %TEMP% 文件夹中的所有文件,然后重新启动 Windows。
  6. 当你尝试更新或安装 EmEditor 时,如果有错误消息“无法访问您要使用的功能所在的网络位置。”显示,首先定位前一版本的安装程序。前一版本的安装程序通常能在 C:\ProgramData\Emurasoft\EmEditor\updates\update… 文件夹中找到。更早的版本可以在 http://files.emeditor.com/emed64_xx.x.x.exe (64-bit) 或 http://files.emeditor.com/emed32_xx.x.x.exe (32-bit) 上下载,这里的 “x” 代表版本号。例如你要下载 v15.6.1 (64-bit) 的安装程序,你的下载链接就是 http://files.emeditor.com/emed64_15.6.1.exe。在命令提示中用“/extract”提取安装程序,例如,如果安装程序是“emed64_15.6.1.exe”,你可以运行: “emed64_15.6.1.exe /extract”。这会用文件内容创建一个子文件夹。在文件夹中,你会找到一个含有“.msi”扩展名的文件,在这个例子中,“emed64_15.6.1.msi”。点击上述对话框中的「浏览」按钮,然后指 .msi 文件。
  7. 如果你无法更新,请先从控制面板卸载旧的版本,然后重新启动 Windows。确保 EmEditor 的安装文件夹是空的 (通常是 C:\Program Files\EmEditor or %LOCALAPPDATA%\Programs\EmEditor),然后安装新的版本
  8. 用 Windows 更新疑难解答工具来查看 Windows 系统。(Windows 10Windows 8.1 或之前的版本)
  9. Microsoft Fix it 工具来检查 Windows 安装程序的系统。
  10. 在作为管理员帐户运行的命令提示中用 Chkdsk 命令来检查硬盘。这个过程可能要花几个小时。
  11. 在作为管理员帐户运行的命令提示中用 sfc /SCANNOW 命令检查系统这个过程可能要花几个小时。
  12. Windows 系统还原也许能把你的电脑设定还原到一个更早的日期。
  13. 如果因权限问题无法卸载 EmEditor,请尝试创建一个管理账户,然后用新账户卸载。
  14. GeekUninstaller (freeware)Revo Uninstaller (freeware) 也许能够帮你卸载一个旧版。
  15. 如果“检查更新”命令无法运行,请到帮助菜单下选择“自定义更新检查程式”,然后确保指定的下载文件夹是可写的。默认的文件夹是 C:\ProgramData\Emurasoft\EmEditor\updates\。
  16. 当更新 EmEditor 时,如果必须重启一个系统,请在更新 EmEditor 之前关闭所有应用程序。特别是 Brother 控制中心 (BrCtrlCntr.exe),如果你安装 Brother 打印机的话。这个应用程序可能会打开 EmEditor 文件夹,因此请到任务栏通知区域内关闭该控制中心。如果还是无法执行更新,请用进程资源管理器搜索任何 EmEditor 安装文件夹的打开句柄当提示系统重启时。
  17. 要报告安装过程中出现的问题,请用 “/L*V log.txt” 运行安装程序。例如,如果安装程序是 emed64_15.7.0.exe,请运行 “emed64_15.7.0.exe /L*V log.txt”。如果要安装到整台电脑上,你必需有管理员权限来运行命令提示。要报告卸载过程中出现的问题,请运行与你想要用 “/L*V log.txt” 卸载的想对应版本的安装程序。压缩日志文件 “log.txt”,然后电邮到技术支持 tech at emurasoft.com。

安装

你能告诉我怎么安装最新版本的EmEditor吗?

您可以在EmEditor网页上下载最新版本的编辑器。步骤如下:

1. 请关闭在运行的EmEditor托盘图标。(要关闭托盘图标,您可以在任务栏上右击托盘图标,然后选择“关闭托盘图标”)。

2. 从控制面板中先卸载前一版本的EmEditor。

3. 信息框会出现提示信息:“在完全卸载EmEditor前,您想要EmEditor的设置保持不变吗?”如果您想要保留原来的设定,请选择“是”。我们推荐您选择“否”,除非您非常需要保留原来的设定以继续完成你的工作。

4. 选择要下载的EmEditor版本和配置。您可以用下面的链接来下载:

下载 EmEditor

5. 当您点击下载链接后,会出现一个文件下载-安全警告对话框。

6.请点击“运行”,然后会弹出一个网络浏览器-安全警告对话框。

7. 选择发布商:Emurasoft, Inc.

8. 请确保在电子签名细节对话框中有“电子签名可用”这个信息。如果这个信息没有在对话框中显示,那么下载的文件可能被损坏了。这样您就需要先清除临时的网络文件(Temporary Internet files),再尝试下载一次。点击“确定”关闭对话框。

9. 请点击“运行”键来开始安装程序。你只需照着屏幕上出现的指令一步一步做就可以完成安装了。

我现在使用的是旧版的EmEditor。我能不用卸载旧版的EmEditor就安装新版本的EmEditor的吗?

如果您使用的是 EmEditor v3.00 或 v3 以后的版本,并且想要保持以前使用的 EmEditor 配置设定的话,您不需要卸载就可以覆盖旧版。您可以在同一个目标文件夹中安装最新的版本。但是您在安装新版本之前,必须完全退出 EmEditor 程序,包括托盘图标也要关闭。如果您在安装的过程中被要求重启 Windows,那您也需要重启 Windows.

如果您用的 EmEditor 版本在 v3.00 以前,也不想要保持以前使用的 EmEditor 配置设定的话,我们推荐您可以先完全卸载以前的版本,重新启动计算机,然后再安装新版本。具体步骤如下:
1. 选择「开始」菜单中的“程序和功能”。从“卸载或更改程序”中选择 EmEditor (或 EmEditor v3)。然后点击“删除”按钮。
2. 当卸载完成后,重新启动 Windows。
3. 按屏幕指示,安装新版本。

旧版和新版的EmEditor能在同一个计算机上共存吗?

不能。旧版和新版的EmEditor不能在同一个计算机上共存。

在启动或编辑中,如果EmEditor突然出故障了,怎么办?

1. 如果您有安装插件,那么请在插件文件夹中把所有插件删除,然后试着再运行一次EmEditor。
2. 如果程序还是不能正常运行,请到「开始」菜单中的“程序和功能”中卸载EmEditor。重启计算机然后再次安装EmEditor。
3. 如果EmEditor只在打开UTF-8或Unicode的文件时出故障,请到编辑器中的“查看”下拉菜单,选择“字体”,并在“字体分类”列表中选择“标准”,然后在“显示字体”方块旁按一下“更改”按钮查看是否选择了合适的字体。

怎么才能永久移除EmEditor托盘图标?

请再次运行EmEditor的安装程序并确保“添加托盘图标到任务栏”的复选框没有被勾选。这样,您就不会再在任务栏中看到EmEditor的托盘图标了。您不需要在运行EmEditor安装程序前卸载EmEditor。如果操作不成功,请在Windows「开始」菜单中选择“搜索”,然后搜索 “emeditor.lnk”文件。这个文件应该在启动文件夹(Startup folder)中。要永久删除EmEditor托盘图标,你可以删除这个文件。

怎么能不用显示对话框就安装EmEditor?

在正常安装的情况下,你会看到屏幕显示对话框指示您完成一系列的安装步骤。但是,如果您想把EmEditor安装到公司,团体或个人使用的多台电脑中时,您可以用一个批处理文件或脚本文件让电脑自动完成安装并简化安装步骤。EmEditor使用Windows安装程序来进行安装,所以如果你不想看到对话框的话就可以把它们都屏蔽掉。

假设你要安装的EmEditor的文件名是emed64_15.1.2.exe 的话,请运行接下来的命令:

emed64_15.1.2 /exenoui /q MSIINSTALLPERUSER=1

这样,EmEditor在安装时就不会出现任何对话框。如果您想更改默认设置的话,您也可以使用以下的一些选项:

MSIINSTALLPERUSER=1 指定当前用户的安装位每个用户安装。如果没有指定,会默认为所有用户安装。
NOCHECKUPDATES=1 禁用定期到网络上查看最新版本 EmEditor 功能。
NOCONTEXTMENU=1 禁用添加一个快捷键到资源浏览器上的上下文菜单中。
NODESKTOP=1 禁用添加一个快捷键到桌面。
NOIEEDITOR=1 禁止把 EmEditor 添加至 IE 浏览器 HTML 编辑列表中。
NOIEVIEW=1 禁用在 IE 浏览器中用 EmEditor 查看源代码的功能。
NOPATH=1 禁止把到 EmEditor 的路径添加到 PATH 环境变量中。
NOSHORTCUT=1 禁止添加一个快捷键到程序菜单中。
NOSKIP=1 即使在更新时,也不跳过安装程序屏幕。
NOTRAYICON=1 禁用托盘图标。
NOTXT=1 禁用文本文件关联。
REGNAME=”name” 输入授权用户姓名。
REGKEY=xxxxxx 输入注册密钥。

如果您想要用注册密钥和用户名仅为当前用户安装 EmEditor 的话,可以运行下列命令(参考用):

emed64_15.1.2 /exenoui /q MSIINSTALLPERUSER=1 REGKEY=xxxxx REGNAME=”John Doe”

如果你要用注册密钥和用户名位所有用户安装 EmEditor,请在管理员特权下执行以下命令(参考用):

emed64_15.1.2 /exenoui /q REGKEY=xxxxx REGNAME=”John Doe”

Windows安装程序还有许多别的选项。具体信息,请运行下面的命令:

msiexec /?

屏幕会显示一系列可以操作的命令。

备注:
如果你要为所有用户安装 EmEditor,安装程序一定要在管理员特权上运行,来避免“用户帐户控制”提示。例如,如果您要在命令提示符上运行安装程序,您需要在按 SHIFT 键的同时右击命令提示符图标来打开命令提示符窗口,然后选择以管理员身份运行。如果你仅为当前用户安装 EmEditor,你必须指定 “MSIINSTALLPERUSER=1″。

怎么变更安装文件夹?

默认情况下,安装文件夹与之前版本的文件夹相同;如果是第一次安装,那么会是 %LocalAppData%\Programs\EmEditor (每个用户安装) 或 \Program Files\EmEditor (每台机器安装)。要更改安装文件夹,请以管理员身份打开命令提示符,然后用 NOSKIP 选项运行安装程序。

例如,EmEditor 安装程序文件是 emed64_16.1.5.exe,你想要安装 EmEditor 到不同的文件夹中,请执行以下的命令 (参考用):

emed64_16.1.5.exe NOSKIP=1

这个命令会在安装过程中帮你选择“自定义”安装,让你能更改安装文件夹。

注意: 你不能更改安装文件夹如果 EmEditor 是每个用户安装。你必须选择为所有用户安装 EmEditor 选项。

不同版本的 EmEditor 无法同时存在在一台电脑上。如果旧的版本已经安装了,你必须先卸载旧的版本,或安装新的版本到与旧版本相同的文件夹中。

怎么安装EmEditor 语法文件?

1. 在“工具”下拉单中,把鼠标指向“选择配置”。

2. 在列表的底部点击“定义配置”。

3. 点击「新建」按钮,选择“使用默认配置”然后点击「确定」。

4. 输入一个描述性名称然后按回车。

5. 点击一下「属性」按钮,然后选择“高亮(1)”标签页。

6. 点击「导入」键,打开合适的语法文件。

7. 最后,点击「OK」关闭“配置属性”对话框。

如果您想要启用关联的扩展名或指定一个扩展名的话,要先把EmEditor设定为与该配置相关联,请进行下面几步操作:

8. 到“工具”菜单下,先择“文件关联配置”。

9. 点击「新建」按钮。

10. 用通配符输入文件扩展名,例如 “*.ext”。

11. 选择新设定的配置名称。

我使用的是新版本的EmEditor。我能不卸载新版,就安装一个旧的版本吗?

不能。您必须先卸载新版,才能安装旧版。如果不这样做的话,会导致不同EmEditor版本的DLL文件不相容。在您卸载新版本之前,您要先退出所有EmEditor窗口,包括托盘图标。在安装过程中,您会被询问是否要保留所有以前的设置。请选择”Yes”,如果你想保留所有的自定义设置。如果Windows系统要求您在安装过程中重启电脑,您也需要重启一下电脑。

在EmEditor 专业版安装完成后,关联的文本文件图标没有显示为EmEditor的图标。

EmEditor 专业版不再更改文本文件的图标了。如果您想要用EmEditor的图标来显示所有的文本文件图标,请到“工具”下拉单中选择“自定义”,在打开的对话框中转到“文件”标签页上。点击“与EmEditor关联”。 如果列表中有“txt”图标,请选择“txt”图标, 然后点击「属性」按钮,确认在“本文件的事例图标”下的文件是emedres.dll文件(通常显示的文件路径是:C:\Program Files\EmEditor\emedres.dll)。也请确认在“当前图标”中您有选择与“txt”相匹配的图标。如果列表中没有任何图标选项,请选择“添加”来创建关联图标。您可以在“当前图标”中选择任何图标,然后输入”扩展名”和“文件类型”,最后,点击“确定”。之后,您会在”与EmEditor关联”的列表中看到您添加的要与EmEditor关联的图标。

EmEditor 不运行

如果您有安装Trend Micro Internet Security系统,并且是最新的安全更新系统的话,EmEditor可能会出现启动不了的问题。请卸载Trend Micro Internet Security ,或在桌面上清除Trend Micro Internet Security的快捷键,问题就会解决。

怎么创建64位便携版本?

要创建64位配置的便携版, 您可以:

1. 从EmEditor网站上下载EmEditor Professional (64位安装程序)。

2. 右击Windows图标,在“运行”对话框中输入下面的命令。一个子文件夹就会被创建。

(文档路径) emed64_14.3.1.exe /extract
(假设安装的程序文件是 emed64_13.0.2.exe )

3. 把整个文件夹复制到一个便携的装置中,例如USB 移动硬盘中。

4. 在同一个文件夹中,创建一个空文件,例如 eeUselni.ini 。

以上就可以完成创建 EmEditor 64位配置的便携版本。

破解,KEYGEN,序列

请详见 破解,Keygen,序列 页

卸载

我在使用EmEditor试用版本之后决定不购买。我怎么卸载?

请关闭所有在运行的EmEditor程序 (注意:EmEditor 帮助也要关闭。如果您正在从帮助上阅读此页,我们推荐您把步骤写下来,或者也可以去我们的网站-支持常见问题卸载中查看。) 点击Windows操作系统中的「开始」菜单,选择“程序和功能”,然后从“卸载或更改程序”中选择 EmEditor,点击「删除」按钮。然后按照EmEditor卸载对话框的指示完成卸载。我们推荐您在完成卸载后,重新启动Windows。

我已经卸载了EmEditor。但是,当我双击打开一个文件时,我的电脑还是在寻找EmEditor程序。由于EmEditor程序已不存在,我无法打开文件,怎么办?

如果您以前有把文件与EmEditor关联,那么这些关联应该在您卸载EmEditor之后被还原。但是,如果您在别的应用程序中,比如资源浏览器中,把文件关联到EmEditor,那您需要自己还原关联设置。打开Windows资源浏览器,找到一个你要打开的文件,右击此文件,选择“属性”,在弹出的对话框中,找到“文件类型”,按一下「更改」键,您就可以选择要用哪种应用程序打开该文件了。

在我卸载EmEditor之后,当我在IE浏览器上的上下文菜单中选择“查看源”后,为什么源代码不显示在记事本中?

一些比较早版本的EmEditor不能够完全卸载注册信息。您需要右击「开始」菜单选择“运行”,然后输入“RegEdit.exe”,在点击「确定」键来启用注册表编辑器。请在注册表编辑器中搜索HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Editor 然后删除该项。

在卸载EmEditor之后,emedtray.exe 和 emedres.dll 文件仍然在C:Program FilesEmEditor中,我要怎么删除这些文件?

当您卸载EmEditro之后,这些文件应该就会被自动从您的电脑上删除了。要手动删除这些文件,您首先要确认运行EmEditor的快捷方式,也就是任务栏上的EmEditor托盘图标是否已经被关闭了。
要永久删除EmEditor的托盘图标的话,请参考下面的链接:

Q:怎么才能永久性地移除EmEditor托盘图标?

如果任务栏上还是显示EmEditor的托盘图标,请您先关闭这个图标,然后删除emedtray.exe 和 emedres.dll 文件。

我不能从控制面板上的“卸载或更改程序”中卸载旧版的EmEditor, 我要怎么做?

如果您无法卸载一个旧的版本,请用“/L*V log.txt”指令来运行旧版的安装程序,这样就会为卸载该程序创建一个日志文件(log file)

例如,如果安装程序名是“emed64_14.3.1.exe”,请运行下面的指令:

emed64_14.3.1.exe /L*V log.txt

这个 log.txt 文件可能含有非常有用的信息,比如为什么安装程序停止工作。

注意:旧版的安装程序能在 C:\ProgramData\Emurasoft\EmEditor\updates\update… 文件夹中找到。

如果您在卸载或安装一个新的版本时,看到下面的对话框内容:

“您试图使用的功能在一个不可用的CD-ROM或其它移动磁盘上。请插入 ‘EmEditor Professional (…)’ 磁盘并点击确认。”

首先,请先找到旧版的安装程序。用 “/extract” 把该安装程序提取出来。例如,如果安装程序是 “emed64_14.3.1.exe”,您可以运行下面的指令:

emed64_14.3.1.exe /extract

这将创建一个子文件夹。在这个文件夹中,您将会看到一个有着 “.msi” 扩展名的文件,在我们举的这个例子中,您会看到文件名显示为 “emed64_14.3.1.msi”。

当您卸载时,看到了以上所述的对话框内容,请点击「浏览」按钮,并指定上面的 .msi 文件。继续这个过程,您应该可以卸载旧版的EmEditor。

如果您不确定您需要哪一个 .msi 文件,您可以查看 log.txt 文件,应该会找到相关信息。

另外,如果当您从控制面板卸载时卸载程序停止运行,请试试看用 GeekUninstaller (freeware)Revo Uninstaller (freeware) 来进行卸载。

如果您还是需要帮助的话,请把具体发生的情况写下来,并和 log.txt 文件一起发送到我们的技术支持部 tech@emurasoft.com。我们会尽快答复您。

文件

当我试着不用扩展名来保存一个文件时,"txt"会被自动添加到这个文件名中。我怎么阻止扩展名被自动添加到文件名中的情况?

在文件名前后用双引号(“”)引起来,就能防止自动添加扩展名。例如,如果你输入的文件名是”File”,那么文件的名称就是File,而不是File.txt。

当打开一个文件时,EmEditor侦测到文件的当前编码是"Western European",即使它只是一个简体中文(GB2312)文件。

在配置属性的“文件”标签页,请不要勾选“全部检测”。 编码检测会出现错误,特别是小文件。

怎么能同时关闭所有窗口?

按下SHIFT键,然后同时点击编辑器右上角红色框框中的”X”。另外,你也可以这样做:

  • 按ALT + SHIFT + F4
  • 按ALT + SHIFT + X
  • 文件下拉单中选择关闭,然后再按一下SHIFT键
  • 在工具栏上添加「关闭全部」按钮,然后点击该按钮。
  • 点击托盘图标,然后在菜单中选择“全部关闭”。

怎么能让“打开”对话框一直显示一个指定的文件夹?

选择工具菜单下的“自定义”,然后在“文件”选项卡上勾选“记住最后打开的文件夹”。

另外,您也可以右击EmEditor快捷方式,打开属性。在“目标”(Target)文本框中的路径后加/cd。例如,如果EmEditor的安装文件夹是“C:\Program Files\EmEditor”,那么请输入”C:\Program Files\EmEditor\emeditor.exe” /cd,并且在“起始位置”(Start in)文本框中输入您要打开的文件夹路径。

怎么保存一个空文件?

选择工具下拉单中的“当前配置属性”,然后在“文件”标签页上点击「保存中…」,在弹出的对话框中清除对“当保存时删除空文件”的勾选。

打印出来的字体太小,怎么办?

请选择工具下拉单中的“当前配置属性”,在“打印”标签页上选择「字体…」,然后你就能更改字体和大小了。

当读取Macintosh文本文件时,一些字符无法正常显示。怎样才能正常地读取Macintosh文本文件呢?

Macintosh 与Windows 系统使用的代码页稍有不同。在Windows 2000/XP/2003/Vista 中,Macintosh 的代码页已经安装了,您能轻松地把Macintosh 文本文件转换成Windows 文本文件。首先,在工具下拉单中选择“定义编码”。在弹出的对话框中,点击“新建”,然后选择一个Macintosh 编码,例如“10001 (MAC – Japanese)”。再选择一个适当的字体类别,例如,Japanese(日文)。点击“确定”,保存设定。

接着,到文件下拉单中,选择“打开…”,在“编码”下拉列表中选择您刚刚设置的编码,您就可以正常读取Macintosh文件了。

在Windows 98/Me中,没有安装Macintosh 的代码页,所以您无法正常读取有特殊字符的Macintosh文件,因为Windows代码页无法读取这些文件。

在一个网络上使用一个共享文件夹,可以阻止别的用户更改我已开启的并且正在编辑的文件吗?

是的。您可以到配置属性的“文件”标签页上,在“被其他程序更改时”旁边的下拉列表中选择“保持锁定”。这样,其他用户就不能打开这个文件了。但是,他们能在您关闭文件之后,编辑并保存更改。

怎么能黑白打印我的文件?

请到“当前配置属性”中的“打印”标签页,勾选“忽略颜色与下划线”复选框。要打印彩色时,请不要勾选该选框。

怎么能加速打开一个大文件呢?

一些配置会降低程序运行的速度。请检查以下几点:

  • 打开“当前配置属性”对话框,到“常规”标签页上,如果“自动换行”列表下的选项不是“不换行”的话,那么EmEditor的速度可能会变慢,因为它要计算哪里要换行。所以,当你要打开大文件时,请选择“不换行”指令。

怎么能把一段中文(或日文、韩文等)的Word文档粘贴到EmEditor上并把它保存为一个文本文件呢?

如果Windows不能正常显示日文,韩文或中文字体,那么您需要到控制面板,选择“时钟,语言和区域”,点击”语言”选项卡,然后安装东亚语言文件

打开您的Word文档,选取要复制的文本,然后按一下 CTRL+C 把文本复制到剪贴板中。

开启一个新的EmEditor窗口后,按一下 CTRL+V 来把剪贴板内容粘贴到EmEditor窗口中。在EmEditor中显示的文字应该是正常的,但如果显示不正常,请从“查看”下拉单中的“字体类别”中选择文字的语言类别。如果还是不能正常显示,请到“查看”下拉单中的“字体”对话框中点击显示字体旁的“更改”按钮,然后从列表中选择一个合适的字体,比如中文是Simsun。

要保存文档时,请选择「另存为」,确保您在编码列表中选择的是Unicode 或是UTF-8。您也可以选择一个区域设置特定的编码,例如简体中文

怎么能用西欧(Western European)而不是UTF-8打开一个XML文件?

如果一个XML文件是作为Unicode被打开的,您可以到“当前配置属性”中,选择“文件”选项卡,然后查看“文件打开时的编码”旁的下拉列表。如果被选择的是“Unicode”,请您把它改为“系统默认”。如果“检测 HTML/XML 字符”复选框被勾选了,一个“encoding=” 的指令会在一个XML文件中被搜寻。如果这个指令被找到了,EmEditor使用这个指定的编码。要注意的是,为目前打开的文件所指定的编码与新建文件或正在储存的文件所指定的编码是不同的。

怎么用西欧(Western European)而不是UTF-8来新建Java文件或XML文件?

在默认情况下,Java文件和XML文件会作为UTF-8打开,当您从文件下拉单中选择新建JavaXML编码文件时。您可以更改配置属性设定来改变这一默认设置。具体步骤是:配置属性->“文件”选项卡->「新建文件…」->”编码”下拉列表中选择“系统默认”。要注意的是新建文件所设的编码可能会与正在打开的或正在保存的文件不同。

EmEditor被指定为另一个应用程序的外部文本编辑器。为什么在EmEditor中做的改变没有在这个应用程序中显现出来?

如果EmEditor被设定为另一个应用程序(例如邮件客户端)的外部文本编辑器,并且这个应用程序监控着EmEditor的操作,这个程序很有可能不会反映用EmEditor保存并修改的内容。要解决这个问题,请用/sp(分离)选项在单独的进程中启动EmEditor (具体操作方式是:右击Windows「开始」菜单->点击“运行”->输入”emeditor /sp”)。这样的话,EmEditor程序就会在一个单独的进程中被运行。

我能打开一个 GB18030 的文件吗?

是的。具体操作如下:

工具->定义编码->新建->编码->简体中文(GB18030)

当您要打开一个文件时,请确认您选择了这个新定义的编码。

怎么用命令行转换文件编码?

您可以参考使用下列的命令行选项:
/cp Encoding —— 打开文件时,指定编码方式。
/cps Encoding —— 保存文件时,指定编码方式。
/sa “DestFile” —— 变换编码后,把文件另存为并重命名。
ss+ —— 变换编码后,用Unicode签名(BOM)保存文件。
ss- —— 变换编码后,不用Unicode签名(BOM)保存文件。

比如,如果您想要把一个文件,Chinese.txt,从简体中文(GB2312)转换成UTF-8,并且想把文件重命名为utf8Chinese,您可以使用如下所示的语法:
emeditor.exe “Chinese.txt” /cp 936 /cps 65001 /ss- /sa “utf8Chinese.txt”

您也参考以下两个链接来编写命令行:
编码常数
如何使用命令行选项

怎么指定用EmEidtor打开特定扩展名的文件?

工具->自定义->“文件”选项卡->与EmEditor关联->添加要用EmEditor打开的文件扩展名

之后,您只要在资源浏览器中双击含有添加的扩展名的文件,就能用EmEditor打开有这些文件。

怎么以独占方式打开文件?

工具->所有配置的属性(如果您已经打开了文件,请选择“当前配置属性”)-> “文件”选项卡->在“被其他程序更改时”旁,选择“保持锁定”。

当我要查看一个当地的HTML文件并保存该文件时,IE浏览器突然终止了,怎么办?

在Windows XP 上,这个情况会出现是因为在配置属性中的“备份”选项卡上,“使用回收站进行备份”的复选框被勾选了。所以,在用IE浏览器查看HTML文件时,请确认该复选框没有被勾选。

在文件前的3个无效字符是什么?

文件顶端的3个无效字符是UTF-8文件的字节顺序标记(BOM)。在默认情况下,Java文件是作为含有BOM的UTF-8文件被创建的。您可以通过取消勾选“添加一个Unicode签名(BOM)”复选框更改这个默认设置。

编辑

怎么用键盘选取文本?

按下F8切换到正常选取模式。按 CTRL + F8 来选取整行;按 SHIFT + CTRL + F8 则变成框选(编辑器中称作“垂直选择”)模式。要改变键盘设定,请到“工具”下的“当前配置属性”中选择“键盘”选项卡,对键盘快捷键进行更改或自定义。

可以插入控制字符,例如换页符吗?

要在EmEditor 中插入控制字符,操作如下:

编辑->高级->插入特殊字符

另一种方法是您可以用 CTRL (+ SHIFT) 加对应的键来输入您要的字符。但是,前提是这个组合没有被定义成别的快捷键,并且,请确认在配置属性中的“常规”选项卡上,“允许插入控制字符”复选框已勾选。

文本内容无法被正常粘贴到EmEditor上。这段文本是从另一个应用程序中复制过来的,比如Netscape Navigator。

一些应用程序在把文本从ANSI转码到Unicode时,会出现一些困难,特别是Netscape Navigator。所以,这时我们不能用常规的“粘贴”命令来获取文本。请按如下步骤操作:

工具-> 所有命令 -> 编辑 -> 粘贴 -> 粘贴为系统默认编码

您也可以这样做:

工具-> 当前配置属性 -> 常规 -> 勾选“总是粘贴为ANSI”

怎么插入特殊字符?

要在EmEditor 中插入控制字符,操作如下:

编辑->高级->插入特殊字符

要检查您想要插入的Unicode字符代码,请参考这个链接:拉丁扩展字符参考
如果您的Windows系统有配置“字符映射表”,您也可以通过单击「开始」按钮,打开“字符映射表”来检查字符。(或在搜索框中,键入“字符映射表”,然后单击查找结果。) 您可能需要调整字体,使文件能正常显示。

同样,请参考“插入特殊字符”来查看特殊字符的键盘快捷方式。

怎么选取一整列的文本?

要框选文本,请使用鼠标选取加ALT键的方式,或者也可以按SHIFT + CTRL + F8,切换到框选模式(EmEditor中称为“垂直选择模式”)。

我要去哪里下载微软Global IME (输入法编辑器)?

微软Global IME 不是必需的,因为其他语言的IME可以到“控制面板”中添加。(「开始」按钮 -> (设置 ->) 控制面板 -> 时钟,语言和区域)。

怎么能用撤消命令来一一删除插入的字符串?

默认设置下,当您点击「撤消」按钮时,一整个插入的字符串会被删除。例如,当您输入”abc”后,点击「撤消」,整个”abc”字符串将被删除。但是,如果您需要点击「撤消」后只删除一个字符,”c”,你可以进行如下操作:

编辑 -> 编辑 -> 勾选“逐格撤销” (您可能需要重启EmEditor)。

怎么把行按字母或数字进行排序?

你可以选择“按字母升序模式排列”,“按字母降序模式排列”,“按数字升序模式排列”,“按数字降序模式排列”命令把行重新排序。这些命令在“编辑”下拉单中的“分开的数值/排序”里。

怎么检查拼写?

在EmEditor专业版v10后的版本中,您可以不使用任何插件就能检查拼写。在EmEditor的上下文菜单中(右键菜单),选择进行“拼写检查”。如果无法看到这一选项,请到“工具”下的“自定义菜单”中选择“上下文菜单”,然后按「重置」按钮。EmEditor 默认安装了英语(美国)字典。其他语言的字典请到extensions.OpenOffice.org(http://extensions.openoffice.org/)中下载。在下载一个字典文件后,请把扩展名从.oxt改为.zip,然后解压缩这个zip文件,并且把 *.dic和 *.aff 文件复制到EmEditor安装文件夹中的Dictionaries(字典)子文件夹中(通常在 C:\Program Files\EmEditor\Dictionaries)。

怎么给特殊字符设置快捷键?

许多特殊字符已经有默认的快捷键方式了。请点击下面的链接查看已设置的一些特殊字符的快捷键:

插入特殊字符

除此之外,您可以用宏给任何您常用到的字符设置快捷键。例如,如果想要用一个快捷键插入ä,您可以编写一个宏(这个例子中,我们会用JavaScript编写):

document.selection.Text=”ä”;

然后把这个文件保存为InsertA.jsee。在“”下拉单中点击“选择…”,并打开InsertA.jsee。当运行这个宏时,EmEditor便会自动插入这个字符。您只需要打开“工具”下的“配置属性”,到“键盘”选项卡上,在“类别”下拉列表中选择“我的宏”,并自定义一个快捷键给这个宏,设定完成后,你就能用你自定义的快捷键来插入这个特殊字符了。

“查找配对的括号”这个命令不起作用。怎么才能启用这个命令?

请到“配置属性”中的“高亮(2)”选项卡上,检查是否所有的“括号对”列表中的选项都被勾选了。然后您可以用 CTRL+] 快捷键在配对的括号之间跳转。

当一个大文件被打开时,排序命令将不能启用。什么情况下会禁用排序命令?

两种情况下会禁用排序命令。

1.在“自定义”对话框中的“高级”选项卡上,“使用临时文件的最小文件大小”一定要大于您要打开排序的文件大小。

2.如果您使用的是32位配置的EmEditor,在注册表编辑器中,请找到下面的一项:

HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common

然后把一个新的REG_DWORD值,MaxReserveBits,设置为Decimal 24(十进制24)或Hexadecimal 0×18(十六进制 0×18)。32位EmEditor的默认值是Decimal 20,64位EmEditor的默认值是Decimal 24。

这些值指定了EmEditor可以排序的最多行数。您不能指定比24大的值,如果指定值是24,那么理论上,允许的最多行数应该是 16777216。然而,如果操作系统无法分配一个大的内存,那么实际允许的最多行数可能会变少。在这种情况下,您可能需要重新启动Windows并且在您再次尝试之前只运行EmEditor。如果您在使用的是64位配置的EmEditor,这个默认值是Decimal 24,因此不必要设置注册表中的值。

有没有可以让光标“撤消”和“重做”的命令?

有,它们被称为“向后”和“向前”。在默认的键盘快捷键中,ALT + LEFT:向后; ALT + RIGHT:向前。有个这两个键,您可以让光标返回到前一个位置,或前进到下一个位置。这两个命令有对应的工具栏按钮,可以通过“自定义工具栏”被添加到EmEditor的工具栏上。

粘贴命令不起作用,怎么办?

请检查一下您的杀毒软件。有时候,杀毒软件会阻止应用程序访问剪贴板。如果是这样的话,你必须要明确地把EmEditor排除在阻止访问剪贴板的应用程序之外。

搜索

怎么用“查找”对话框来显示以前搜索过的字符串,而不是在光标处的单词?

在“查找”下拉列表的右面有一个「>」按钮。点击这个按钮显示下拉菜单,然后选择“自定义”。然后再按一下「>」,在再次显示的下拉菜单中选择“保存为默认”。

怎么把“查找”文本框中所有以前搜索过的字词都清除?

工具 -> 自定义 -> “历史记录”选项卡  -> 「清除历史记录」

在“在文件中查找”对话框中,能在日语(JIS或EUC)文件中搜索字符串吗?

在EmEidotr 专业版中,您能在“在文件中查找”对话框中选择编码,例如日语(JIS)或日语(EUC)。在EmEditor标准版中,您不能指定编码,因此不能搜索日语(JIS)或日语(EUC)的文件。

我能使用正则表达式来查找或替换吗?

是的。EmEditor支持正则表达式。

怎么在行的开头或末尾搜索一个字?

当您在“查找”对话框中勾选了“使用正则表达式”后,行的开头可以用 “^”来表示,而行的末尾可以用 “$” 来表示。所以,要在行的开头部分查找,请在“查找”文本框内输入“^xxxxx”;要在行的末尾部分查找,请输入“xxxxx$”。

您还可以勾选“使用转义符”,这样就能用“\n”来表示新的一行。当您要在行的开头部分查找,你可以输入“\nxxxxx”;当你要在行的末尾部分查找时,可以输入“xxxxx\n”。

正则表达式的例子有哪些?

  • 被双引号包围字符串
    “.*?”
  • 被 [ ] 包围的字符串
    [[^[]*?]
  • 变量名称
    [a-zA-Z_][a-zA-Z_0-9]*
  • IP 地址
    ([0-9]{1,3}).([0-9]{1,3}).([0-9]{1,3}).([0-9]{1,3})
  • URL
    (S+)://([^:/]+)(:(d+))?(/[^#s]*)(#(S+))?
  • 后面跟一个标签(tab)的行
    t.*$
  • 平假名
    [x{3041}-x{309e}]
  • 全角片假名
    [x{309b}-x{309c}x{30a1}-x{30fe}]
  • 半角假名
    [x{ff61}-x{ff9f}]
  • CJK 表意文字
    [x{3400}-x{9fff}x{f900}-x{fa2d}]
  • CJK 表意文字标记
    [x{3000}-x{3037}]
  • 韩文
    [x{1100}-x{11f9}x{3131}-x{318e}x{ac00}-x{d7a3}]
  • 在行的开头插入 //
    查找: ^
    替换为: //
  • 在行的末尾去除 //
    查找: ^//
    替换为:
  • 清除尾部空格
    查找: s+?$
    替换为 with:
  • 把 (abc) 替换为 [abc]
    查找: ((.*?))
    替换为: [1]
  • 把 9/13/2003 替换为 2003.9.13
    查找: ([0-9]{1,2})/([0-9]{1,2})/([0-9]{2,4})
    替换为: 3.1.2.
  • a 到 z 的大写(仅适用于 EmEditor 专业版)
    查找: [a-z]
    替换为: U
  • 所有字符大写 (仅适用于 EmEditor 专业版)
    查找: ([a-zA-Z])([a-zA-Z]*)
    替换为: U1L2

为什么EmEditor不高亮多行字符串?

为了增强程序的性能,EmEditor 的设计是一行一行高亮字符串,而不是高亮包含新行的字符串。

查找/替换对话框太大了。

您可以把鼠标指针移到查找/替换对话框的右下角来调整该对话框的大小。

怎么在查找/替换对话框中把多行字符串作为要搜索的字符串?

在“查找”下拉列表的右边有一个「>」按钮。点击这个按钮,选择“多行”。然后,您可以把鼠标移到对话框的右下角使对话框变大,让你能输入多行的字符串。要换行输入时,请使用CTRL + ENTER (回车)来换行。

查看

原来光标的形状是这样“|”,但现在它变成了一个实心的长方块形状。当我打字时,它不是输入文字,而是改写存在的字符。怎么办?

发生这种情况是因为您的EmEditor中的“改写”模式被启用了。请按一下键盘上的“Insert”键来切换“插入/改写模式”。

怎么用记号标示单字节的空格?

到“配置属性”下的“标记”选项卡,勾选“显示空格”复选框。

当我用默认设置打开一个文件时,文件变为不可读;如果我从“查看”下的“字体分类”选项中选择另一个字符集,文件看起来更糟糕。但是,如果我在打开文件时选择一个合适的编码,文件则能正常显示。这是怎么一回事?

EmEditor的内部处理编码是Unicode。当您打开一个ANSI文件时,EmEditor可以把ANSI文本转换为Unicode文本。当您要打开一个文件时,应该在“打开”对话框中选择一个编码,如果您不这样做,EmEditor会用系统默认编码来打开文件。所以,要用一个不同的编码来打开文件,您需要指定打开该文件的编码。如果您已经用一种编码打开了文件,您可以去“文件”菜单下的“重新载入”来选择不同的编码重新载入文件。

我什么时候要使用“查看”菜单下的“字体分类”?

EmEditor无法从Unicode文件中检测语言。您必须在“查看”菜单下的“字体分类”中选择一个合适的类别来显示非系统默认的字体集。当创建一个新文件时,如果您要使用的语言是非系统默认的字体集,您也需要去“查看”菜单下更改字体类别。

在从一个页面到另一个页面时,怎么才能让编辑器显示连续的行号?我以前没有遇到过这个问题,但是现在我的配置好像被变更了。

在“当前配置属性”对话框中的“常规”选项卡上,请清除勾选“显示页码”复选框。

什么是逻辑坐标和显示坐标?什么是一个逻辑行?

逻辑坐标指的是一个文档中的坐标,不管这个文档是用哪一种换行模式。在逻辑坐标中,因为要换行而产生的回车符不算在内。逻辑行指的是一个文档中行的总数减去换行产生的行。显示坐标,则包括换行后的行。

我在EmEditor窗口的左边有显示行号,但是,要换行时,我不想让行号也随之递增。我该怎么做?

当前配置属性 -> 常规 -> 在“行列显示”下的下拉列表中选择“逻辑坐标”中的一个。

我不喜欢新的像玩具一样的Windows XP 样式工具栏。能显示旧的工具栏按钮吗?

可以。工具 -> 自定义工具栏 -> 勾选“16色”。

我能把任务栏上的托盘图标用我最喜欢的图标来显示吗?

可以。到注册表编辑器(RegEdit.exe)中,找到:HKEY_CURRENT_USERSoftwareEmSoftEmEditor v3Common ; 创建一个TrayIconFile值并把它定位REG_SZ, 然后设置图标文件路径,把TrayIconIndex 值设为REG_DWORD,并设置图标索引。

怎么能用不同的颜色再次高亮以前搜索过的字符串?

当前配置属性 -> 显示 -> 在“搜索高亮”旁的编辑框中更改您想要高亮显示的搜索次数;要让不同的搜索内容显示不同的高亮颜色,请把“指定部分”下的列表框拉到最底行,选择“搜索字符串(1),(2)…,然后在“背景颜色”或“文本颜色”中选择来显示不同颜色的搜索字符串。

怎么在光标处显示下划线?

当前配置属性 -> 滚动 -> 勾选“水平线”

怎么在显示URL时,不用在特定的字符处断开?

当前配置属性 -> 链接 -> 在“识别这些字符”文本框中填入你不想要断开URL的字符(例如“,”逗号)。

光标竖线很窄,能让它变宽吗?

在Windows Vista中,您可以到“控制面板”中选择“优化视觉显示”,把“设置闪烁光标的粗细”的数字调大。
在Windows XP中,您可以到“控制面板”中选择“辅助功能选项”,然后去“显示”选项卡,在“光标选项”下调整“宽度”。

如何查找选取的文本字数?

您可以使用“字数统计”插件,这个插件在EmEditor专业版v6之后就成为EmEditor专业版的内置插件之一。如果您使用的是EmEditor标准版,请到资源库下载这个插件。

怎么用Unicode字符解码数字字符引用("&#xx")?

请按照以下的步骤操作:
编辑 -> 编码/解码已选定的文本 -> 将HTML/XML字符参考转换为Unicode

怎么知道每行的换行方式(例如,CR,LF,CR+LF)?

请在“自定义”对话框中的“状态栏”选项卡上勾选“光标处字符的字符代码”。当光标在任一行的行末处时,您会看到EmEditor窗口中的状态栏上分别显示0D+0A (CR+LF),或0D(仅仅CR)或0A(仅仅LF)。
另外,您可以到配置属性中的“标记”选项卡上勾选“使用不同的标记来显示CR与LF”来标示不同的换行方式。由于在EmEditor中每一行都可以有不同的换行方式,如果您勾选了这个选项,EmEditor会显示每一行的换行方式。

怎么把「标记」按钮添加到工具栏上?

请双击工具栏(含有最基本的工具按钮的那一个)的边框。在弹出的“自定义工具栏”对话框中选择「标记」按钮,然后“添加”。另外,你也可以到“工具”菜单下选择“自定义工具栏”,双击“工具栏1”,在弹出的对话框中添加「标记」按钮。

怎么显示行号?

当前配置属性 -> 常规 -> 勾选“显示行号”

在XHTML和HTML文档中,XML文件,标签文本和光标处匹配的标签被高亮显示。怎么终止这个行为?

请按以下步骤操作:
当前配置属性 -> 高亮(2) -> 清除勾选“高亮匹配标签”

怎么更改用户界面语言?

自定义 -> 语言 -> 选择您要使用的界面语言

自定义

当我点击邮件地址时,怎么用我最喜欢的e-mail程序发送邮件?

要让您想要使用的e-mail程序成为EmEditor默认的e-mail软件,请到“控制面板”中的“Internet选项”去,选择“程序”选项卡,您可以在“设置默认程序”中设置您想要默认使用的e-mail程序。
如果您的电脑系统不支持以上的操作,您可以到资源管理器中的“查看”菜单下选择“选项”,然后点击“文件类型”选项卡,更改”URL:Mail To Protocol”的设定。请双击“打开”键,并在“用于执行操作的应用程序:”栏中输入你要使用的e-mail软件路径及选项。您也可以参考e-mail程序中的说明来输入软件路径和相关选项。要注意的是,一些e-mail程序并不支持此功能。

点击URL时能用我喜欢的网页浏览器打开网页链接吗?

当您安装了另一个浏览器时,您会被询问是否要把这个浏览器设置为默认浏览器。然后,在EmEditor中点击任何URL便会立即启动您设置为默认的浏览器。

怎么让插入的日期年份以4位数显示?

请到“控制面板”中的“区域设置”设定日期的显示方式。这与记事本(Notepad)中的规范是一样的。

怎么把配置属性中的设定复制到另一台电脑上?

如果您使用的是EmEditor v5 或v5后的版本,你可以到“工具”菜单下的“导入和导出”中,根据自己的需求选择导出当前设置的方式,然后在另一台电脑上导入设置。
对于EmEditor v5 之前的版本,您需要用注册表编辑器(Regedit.exe)把HKEY_CURRENT_USER\Software\EmSoft\EmEditor v3 项写入一个文件中,把这个文件复制到另一台电脑上,然后通过注册表编辑器读取文件。 您可能需要通过手动在“属性”中来变更文件夹名称。

为什么没有ASP配置?

ASP语法被包括在HTML配置中,并且根据VBScript或JavaScript配置的设定,嵌入的脚本(通常用VBScript或 JavaScript编写)也会被高亮显示。

关于配置属性中“高亮(2)”选项卡上的“特殊语法”的选项,什么时候适合选择“HTML”,什么时候要选择“HTML-嵌入”?

当指定脚本语言的HTML标签(SCRIPT type=…)出现在HTML文档中时,您可以选择“HTML”。“HTML”的选项同时也适合ASP文件,包括以%符号开始的脚本,诸如 VBScript, Javascript, PerlScript, CSS等等。当您使用在#ScriptBegin中指定的标示脚本语言开头的字符串时,例如PHP或JSP中的%和?,“HTML-嵌入”的特殊语法会比较适合。

当保存HTML或XML文件时,EmEditor能够把Unicode字符编码为“数字字符引用”(NCR,如 &#xx)吗?

是的。在配置属性中的“文件”选项卡上,点击「保存中」,然后勾选“把Unicode保存为HTML/XML字符引用”。您也可以勾选“使用命名实体引用”如果您想要保存诸如像©的命名实体引用。如果您的配置是HTML和XML配置,这些复选框都会被默认勾选。但是,当加载HTML 或 XML 文件时,EmEditor目前不能把NCR解码或显示为Unicode字符。

在“文件”菜单下“重新载入”的子菜单中,除了相同编码,系统默认,UTF-16LE,UTF-16BE,UTF-8,和UTF-7之外,没有其他编码可用。我怎么添加更多的编码页?

如果您没有适当地安装EmEditor,只是把emeditor.exe文件从一台电脑复制到另一台电脑并且尝试运行程序,那么一些系统内设置的编码可能不会在EmEditor复制版中显示。如果您使用的是Windows NT/2000/XP,要安装另外的编码,您可以作为高级用户(Power User)或管理员身份登入,并在“工具”菜单下,选择“定义编码”,然后点击「重置」。编码的可用性取决于安装在Windows中的语言系统文件。如果您无法在EmEditor中找到您要的那种编码,您可以到“控制面板”中的“区域和语言选项”安装额外的语言文件。当语言系统文件安装到你的Windows系统中后,再次到EmEditor中选择“定义编码”,点击「重置」。

在更新EmEditor后,怎么把新命令添加到一个菜单中或添加新的快捷键?

如果新命令没有在菜单中显示,请到“工具”菜单下的“自定义菜单”中,点击「重置」按钮,还原菜单的默认设置。要添加新的命令快捷键,请到“所有配置属性”中的“键盘”选项卡上点击「重置」。

怎么定义两次按键的键盘快捷方式?

您可以通过整合用户菜单特性和键盘映射特性来定义两次按键的键盘快捷方式。通过定义用户菜单(1),CTRL+K 已经被预先设置为第一个两次按键的键盘快捷方式。

一些系统预先定义的快捷键包括:
CTRL+K, K 切换书签
CTRL+K, N 当前文档中的下一个书签
CTRL+K, P 当前文档中的上一个书签
CTRL+K, L 清除当前文档中的所有书签
CTRL+K, C 注释选定内容
CTRL+K, U 取消注释选定内容

在这个列表中,在您按第二个键之前,可以按也可以不按CTRL键。例如,切换书签指令的快捷方式是先按CTRL键和K键,然后你可以再按一下K键,或再按一下CTRL键和K键。两种方式都可以。

添加新的两次按键的键盘快捷方式:
1. “帮助” -> “键盘布局”
2. 如果您想要所有EmEditor的配置都使用同样的快捷方式的话,请点击工具栏上的「键盘布局设置」,选择“所有配置”。
3. 在列表中找到“用户菜单(2)”并双击。
4. 在弹出的“所有配置属性”对话框上的“按下新的快捷键”中输入一个新的快捷键方式。例如,CTRL+;
5. 点击「分配」 -> 「确定」
6. 关闭“键盘布局”窗口。
7. “工具” -> “自定义菜单”
8. 在“需要定义的菜单列表”下选择“用户菜单(2)”
9. 点击「插入右边」按钮。
10.在弹出的“菜单属性”对话框中,选择一个要添加快捷键的命令。
11.在对话框中的“名称”文本框中,用“&”指定一个新的快捷键。
12.在“&”的右边输入字符,这个字符代表第二次要按的快捷键。

例如,如果你想要给“新建并粘贴”命令设置一个两次按键的快捷方式并把”N”设置为第二个快捷键,操作如下:
13.在“菜单属性”对话框中的“类别”组合框中,选择“文件”。
14.在“命令”组合框中选择“新建并粘贴”。
15.在“名称”文本框中输入”&New and Paste”(“&”右边的字符”N”代表第二次要按的快捷键)
16.点击「确定」。

重复以上的步骤,你就可以给你要的许多的命令设置快捷键。

在默认情况下,用户菜单会在按第一个键的1秒后出现。第二个快捷键在用户菜单出现之前有效。您可以到“自定义菜单”中移动“延时”滑块,让菜单出现的时间延长。

CTRL+鼠标滚轮能改变字体大小,但是如何能禁用这个快捷方式?

您可以在“自定义”对话框中的“鼠标”选项卡上,清除“使用CTRL加鼠标滚轮调整字体大小”的复选框。

双击EmEditor中的一个标签页可以在一个新窗口中显示该标签页。可以禁用这个功能吗?

可以。请去“自定义”对话框中的“鼠标”选项卡上,如果“双击鼠标左键”下的下拉单中的选项是“新建分组”,请把它改成“未定义”。

工具

我可以在EmEditor中运行一个外部的编译器来编译当前文件吗?

请参考FAQ:外部工具配置的例子有哪些? -> 由 Visual C++ 编译

怎么在Google搜索中查找当前光标位置处的单字?

请到“工具”菜单下的“外部工具”中,选择“自定义工具”,然后点击「新建」按钮,在“命令”文本框中输入“http://google.com/search?q=$(CurText)”

我想要在命令提示符中用一个外部工具编译已打开的文件,但是在编译完成后如何能让命令提示符窗口保持开启?

选择“外部工具”子菜单下的“自定义工具”,点击「新建」按钮并在“命令”文本框中输入“cmd.exe”,然后在“参数”中输入:/k “filename” $(Path) 。

外部工具配置的例子有哪些?

  • 打开IE浏览器
    命令:C:\Program Files\Internet Explorer\iexplore.exe
    参数:$(Path)
    初始目录: $(Dir)
    图标路径: C:\Program Files\Internet Explorer\iexplore.exe
    检查保存文件
  • 打开资源浏览器
    命令: %WinDir%\explorer.exe
    参数: $(Dir)
    初始目录: $(Dir)
    图标路径: %WinDir%\explorer.exe
  • 打开命令提示符
    命令: %WinDir%\system32\cmd.exe
    参数: $(Dir)
    初始目录: $(Dir)
    图标路径: %WinDir%\system32\cmd.exe
  • Visual C++ 编译
    命令: %WinDir%\system32\cmd.exe
    参数: /k “C:\Program Files\Visual Studio\Vc7\bin\vcvars32.bat”&&cl $(Path)
    初始目录: $(Dir)
    图标路径: C:\Program Files\Visual Studio\Common7\IDE\devenv.exe
    检查保存文件
  • 运行相关程序
    命令: $(Path)
    参数:
    初始目录: $(Dir)
    图标路径:
    检查保存文件
  • Google搜索在光标处的单字或一段选取的文本。
    命令: http://google.com/search?q=$(CurText)
    参数:
    初始目录:
    图标路径:
  • Microsoft Visual SourceSafe 签出
    命令: %WinDir%system32cmd.exe
    参数: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkout $/(path)/$(Filename).$(Ext) -y(user name)
    初始目录: $(Dir)
    图标路径: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE
  • 签入到 Microsoft Visual SourceSafe
    命令: %WinDir%\system32\cmd.exe
    参数: /k C:\(SourceSafe path)\Common\VSS\win32\SS.EXE checkin $/(path)/$(Filename).$(Ext) -y(user name)
    初始目录: $(Dir)
    图标路径: C:\(SourceSafe path)\Common\VSS\win32\SSEXP.EXE
    检查保存文件

您能在命令,参数,初始目录,图标路径中使用下面预先定义的参数。
$(Path) 文件的完整路径名称。
$(Dir) 文件的目录名称。
$(Filename) 扩展名之外的文件名。
$(Ext) 文件名的扩展。
$(CurLine) 光标处的逻辑行行号。
$(CurText) 选取的文本或在光标处的单字(如果没有选取的文本)。

您还能指定环境变量,例如 %WinDir%。

我能使用VBScript MSgBox功能吗?

不行。但是,您可以用WshShell的Popup方法。您还能用alert或confirm方法来代替。
请参考“显示一个消息框”。

我能把多个宏保存到文件中吗?

可以,您能通过“保存宏”命令把已录制的宏保存到文件中。

窗口

分割窗口有什么作用?

当您在文本底部编写时,分割窗口可以让您同时查看文本顶部。但是,您不能在分割窗口的每一个窗格中打开不同的文件。

怎么保存EmEditor窗口的大小,并能在每次打开EmEditor时一直保持这个窗口的大小?

首先,请把EmEditor窗口调整到合适的大小,然后选择“工具”菜单下的“自定义”,到“窗口”选项卡上,点击「保存当前窗口位置」按钮,然后点击「确定」。

怎么能使每次打开EmEditor窗口时都最大化?

首先,请最大化EmEditor窗口。选择“工具”菜单下的“自定义”,到“窗口”选项卡上,点击「保存当前窗口位置」按钮,再勾选“还原窗口位置”复选框,最后点击「确定」。

怎么保存所有EmEditor窗口的当前位置,并在下次开启EmEditor时,同时打开所有的窗口?

用鼠标左键点击EmEditor的托盘图标来显示托盘图标菜单,并且选择“保存工作空间”命令来保存所有的文件名和当前工作空间的光标位置。下次,您可以选择“还原工作空间”命令来还原以前保存的窗口,包括同样的文件名和光标位置。

您还能使用“保存工作空间并全部关闭”命令在保存工作区后关闭所有窗口,或者用“保存工作空间与所有文件并全部关闭”命令来在保存工作空间后保存并关闭所有窗口。

如何让EmEditor窗口显示为标签式?

选择“启用标签”命令,让这个命令被勾选。

为什么“层叠”或“平铺”命令不起作用?

当“启用标签”被选择时,选择“层叠”命令或任何“平铺”命令会让标签页不能用。这些命令只能用在当许多分组存在时。因此,这些命令没有任何意义当只有一个分组存在时。这个设定是来自于EmEditor用户的要求。要像之前那样层叠或平铺,请先禁用标签页,然后再选择命令。即使只有一个分组存在,您还是可以用“新建水平分组”“新建垂直分组”这两个命令来平铺窗口。

当我关闭最后打开的文档时,怎么让EmEditor窗口保持开启状态?

请到“工具”下拉菜单中选择“自定义”,然后选择“窗口”选项卡,再勾选“关闭最后的文档时,不关闭窗口”复选框。

能不能在切换标签时,让EmEditor从左到右移动文档标签?

可以。选择“工具”菜单下的“自定义”,到“窗口”选项卡上,清除对“点击‘下一个文档’命令时切换到上次使用的文档窗口”复选框的勾选。当这个复选框没有被勾选时,您可以在标签文档之间从左到右(CTRL+TAB)或从右到左( CTRL+SHIFT+TAB )切换文档。当勾选这个复选框时,按下 CTRL+TAB 和 CTRL+SHIFT+TAB ,会在活动的文档和上一次查看的文档之间切换。

插件

怎么让工具栏自动显示HTML工具栏当打开一个HTML文件时?

在插件栏上的「HTML工具栏」按钮上单击鼠标右键,在出现的上下文菜单中选择“属性”。在弹出的对话框中选择您希望显示HTML工具栏的配置,然后勾选“为选定的配置自动显示HTML工具栏”复选框,点击「确定」,完成设置。当您打开选定的配置时,EmEditor就会显示HTML工具栏。

购买

如果我购买了EmEditor, 我能免费更新到最新的版本吗?还是每次要更新到新版本时,我都需要付注册费?

如果您购买的是永久授权,您以后都可以免费更新到最新的版本。

如果您购买的是常规授权,在1年内是不需要支付任何程序升级更新费用的。1年之后,如果您要再升级到新版本,需要支付$19.99/年的更新维护费。

我怎么知道我电脑上安装的EmEditor是Pro版还是标准版?

您可以去EmEditor上的“帮助”菜单,选择“关于EmEditor”。在弹出的对话框中,你可以查看关于您目前安装的版本信息,包括当前版本是Pro版(“EmEditor Professional”) 还是标准版(“EmEditor Standard”)以及当前的版本号。

常规授权和永久授权之间的差别是什么?

无论哪个授权,您都享有永久使用EmEditor当前版本的权利。
在1年之后,常规授权如果要进行大的升级,需要支付更新维护费,但是如果您买的是永久授权,您可以一直享有免费的升级和更新。

当我试着升级EmEditor时,我看到对话框显示“您需要购买升级”。我怎么知道我是否需要购买升级?

您可以到我们客户中心的重新发送注册码页面上,输入您的电子邮件。如果您所持的授权是永久授权或您的常规授权仍有效,系统会自动给您发送可用的注册码。如果您不符合免费升级条件,系统发送给您的邮件中将包含您的授权所能升级的版本的注册码。

疑难解答

我怎么报告一个损坏?

如果EmEditor有损坏,通常它会在C:\ProgramData\Emurasoft\EmEditor\Error\ 文件夹中创建一个损坏报告。请把这个文件夹中最近的文件(压缩到一个Zip 存档)作为附件电邮到tech@emurasoft.com,请在电邮中描述一下损坏的详细情况,包括重现问题的步骤。

当我启动EmEditor时,它会加载以前运行的大文件。我怎么禁用自动加载?

如果EmEditor试着加载上次使用的工作空间,您可以在命令提示符中,运行:

emeditor.exe /clw

在运行这个命令后,上次使用的工作空间就会被删除,EmEditor 会启动一个无标题窗口。

下载

哪里可以下载EmEditor免费版?

EmEditor 免费版和 EmEditor 专业版使用一样的二进制程序。您可以在我们的下载页面下载EmEditor 免费版/专业版。在您安装EmEditor后,可以选择降级到免费版。您可以在“快速启动”(Ctrl+Q)中输入”降级”来启用“降级”命令。另外,请参考怎么在专业版和免费版之间切换的说明

哪里可以下载旧版的EmEditor?

旧版的安装程序能在 C:\ProgramData\Emurasoft\EmEditor\updates\update… 文件夹中找到。